CCNA, CCNA Exam, CCNA help, Cisco Certified Network Associate, CCNA study, CCNA prep

Passive Interface

Overview:

A passive interface prevents sending OSPF messages out interfaces that are not connected to another OSPF router.

 

Study Notes:

  • Passive interfaces help to more efficiently use bandwidth
  • Passive interfaces help to more efficiently use router resources
  • Passive interfaces lessen the security risk
  • Passive interfaces can be set per interface that is enabled for OSPF or they can be set as default for all interfaces running OSPF and then disabled on an interface by interface basis
  • The command to apply a passive-interface to a specific interface is

OSPF

config t
    router ospf 1 
        passive-interface FastEthernet 0/1
    --or--
    interface FastEthernet 0/1
        ip ospf passive-interface

EIGRP

config t
    router eigrp 20
        passive-interface FastEthernet 0/1
    --or--
    interface FastEthernet 0/1
        ip passive-interface eigrp 20
  • The command to apply a default passive-interface and then remove it for a specific interface is

OSPF

config t
    router ospf 1
        passive-interface default
        no passive-interface FastEthernet 0/0

EIGRP

config t
    router eigrp 20
        passive-interface default
        no passive-interface FastEthernet 0/0

 

Links:

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/iproute_pi/configuration/xe-3s/iri-xe-3s-book/iri-default-passive-interface.html

https://www.cisco.com/c/m/en_us/techdoc/dc/reference/cli/n5k/commands/ip-passive-interface-eigrp.html


Leave a Reply

s2Member®