CCNA 7.4: Configure and verify initial device configuration

Overview:

Initial device configuration is necessary when first powering on a new router or switch.  It can be accomplished through the System Configuration Dialog guide or manually.

 

Study Notes:

  • When powering on a new device, the System Configuration Dialog will prompt you to continue with initial device configuration.  Enter yes to continue being prompted with additional device configuration steps. Enter no to go into User Exec mode.
         --- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]: 

 

  • Basic management setup allows you to configure management access to the device
At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.


Basic management setup configures only enough connectivity
for management of the system, extended setup will ask you
to configure each interface on the system

Would you like to enter basic management setup? [yes/no]: yes

 

  • Next, configure the global parameters
Configuring global parameters:

  Enter host name [Router]: HQRtr

  The enable secret is a password used to protect access to
  privileged EXEC and configuration modes. This password, after
  entered, becomes encrypted in the configuration.
  Enter enable secret: cisco

  The enable password is used when you do not specify an
  enable secret password, with some older software versions, and
  some boot images.
  Enter enable password: cisco1

  The virtual terminal password is used to protect
  access to the router over a network interface.
  Enter virtual terminal password: cisco2

 

  • After that you'll be asked if you want to configure SNMP newtork management.
Configure SNMP Network Management? [no]:

 

  • A list of interfaces is displayed and you will be prompted to select one to be used for the management network.
Current interface summary

Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        unassigned      YES manual administratively down down

FastEthernet0/1        unassigned      YES manual administratively down down

Enter interface name used to connect to the
management network from the above interface summary: FastEthernet0/0

 

  • Having selected the management interface, you will be prompted to configure that interface
Configuring interface FastEthernet0/0:
  Configure IP on this interface? [yes]: yes
    IP address for this interface: 192.168.1.1
    Subnet mask for this interface [255.255.255.0] : 

 

  • The router will display the commands applied based on your previous answers
The following configuration command script was created:

!
hostname HQRtr
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
enable password cisco1
line vty 0 4
password cisco2
!
interface FastEthernet0/0
 no shutdown
 ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/1
 shutdown
 no ip address
!
end

 

  • Following that, the router will ask you what you’d like to do next
[0] Go to the IOS command prompt without saving this config
[1] Return back to the setup without saving this config
[2] Save this configuration to nvram and exit

Enter your selection [2]: 2
Building configuration...
[OK]
Use the enabled mode 'configure' command to modify this configuration.


Press RETURN to get started!


%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down

%SYS-5-CONFIG_I: Configured from console by console


HQRtr>

 

  • That's initial device configuration using the System Configuration Dialog. You'll definitely want to improve upon this configuration by doing things like setting the clock, starting the service to encrypt plain-text passwords, setting exec-timeout values on the console and vty lines, configuring interfaces and routing, and more.
  • To verify, simply show the running configuration
HQRtr>en
Password: cisco 
HQRtr#show running-config 
Building configuration...

Current configuration : 585 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname HQRtr
!
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
enable password cisco1
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 password cisco2
 login
!
!
!
end


HQRtr#

 

PacketTracer Lab: CCNA-7.4-Configure-and-verify-initial-device-configuration.pkt

Subscribe Now for access to the labs!

Leave a Reply
s2Member®